J'ai une image docker hébergé dans le private registry. L'image est correctement hébergé car j'arrive a faire un docker pull dans ma machine et à lancer l'image.
Je souhaite déployer cette image dans le service Kubernetes managé. J'ai suivi ce guide à la lettre, mais à la fin, quand je fait kubectl get pods -l app=… j'ai le statut ImagePullBackOff qui, je suppose, veut dire que kubernetes n'arrive pas à charger l'image depuis le private registry. J'ai regardé dans le dashboard et je vois qu'un 401 Unauthorized est retourné quand kubernetes tente de charger l'image.
Voici une capture de l'erreur affiché dans le dashboard
En général une erreur 401 signifie que soit vos identifiants de connexion ne sont pas bons, soit votre utilisateur n'a pas les droits sur le projet cible. Je vous invite à repartir de 0 et suivre le guide une nouvelle fois. Cela ressemble fortement à une erreur de configuration côté Kubernetes.
Puisque j'ai résolu mon problème je laisse ici la solution pour les prochains visiteurs: je ne sais pour quelle raison, la méthode de création du secret qui autorise kubernetes à pull l'image du private registry, tel que décrite dans l'article, ne fonctionne pas pour moi. J'ai trouvé dans le doc de kubernetes une autre méthode pour creer ce secret. C'est via la commande: ```sh kubectl create secret docker-registry regcred --docker-server= --docker-username= --docker-password= --docker-email= ```