Changement de version PHP sur mon site Joomla

Bonjour,


backend, même pas à l'écran d'accueil où l'on rentre le user et le mdp et ça, je ne vois pas ce qu'un plugin non compatible PHP 8 pourrait avoir à y faire.

Si il elle a des options de configuration dans la partie administration alors cela peut planter toute la partie admin

Là il faudrait regarder les logs dans le manager OVH pour voir si il y a plus d'informations sur l'origine de l'erreur 500.

Cordialement, janus57

Ci-dessous les logs d'hier 26/07/2022

[Tue Jul 26 10:42:19 2022] [warn] [client 10.10.10.10] [host yaya.lu] engine php version 8.0 not available at /var/lib/fastcgi/php//images/legacy/8.0
[Tue Jul 26 10:42:19 2022] [warn] [client 10.10.10.4] [host yaya.lu] engine php version 8.0 not available at /var/lib/fastcgi/php//images/legacy/8.0, referer: http://yaya.lu/phpinfo
[Tue Jul 26 15:14:29 2022] [warn] [client 10.10.10.9] [host www.yaya.lu] engine php version 7.4 not available at /var/lib/fastcgi/php//images/legacy/7.4
[Tue Jul 26 15:14:29 2022] [warn] [client 10.10.10.10] [host www.yaya.lu] engine php version 7.4 not available at /var/lib/fastcgi/php//images/legacy/7.4, referer: http://www.yaya.lu/
[Tue Jul 26 15:14:51 2022] [warn] [client 10.10.10.8] [host www.yaya.lu] engine php version 7.4 not available at /var/lib/fastcgi/php//images/legacy/7.4
[Tue Jul 26 15:23:15 2022] [error] [client 213.186.33.19] [host www.yaya.lu] AH01630: client denied by server configuration: /homez.639/yayasngk/www/administrator/components/com_akeeba/backup/akaccesscheck_01d7f84ead1498f268ed9920c561ddd9.txt
[Tue Jul 26 15:23:15 2022] [error] [client 213.186.33.19] [host www.yaya.lu] AH01630: client denied by server configuration: /homez.639/yayasngk/www/administrator/components/com_akeeba/backup/
[Tue Jul 26 18:49:26 2022] [error] [client 213.186.33.19] [host www.yaya.lu] AH01630: client denied by server configuration: /homez.639/yayasngk/www/administrator/components/com_akeeba/backup/akaccesscheck_01d7f84ead1498f268ed9920c561ddd9.txt
[Tue Jul 26 18:49:26 2022] [error] [client 213.186.33.19] [host www.yaya.lu] AH01630: client denied by server configuration: /homez.639/yayasngk/www/administrator/components/com_akeeba/backup/
[Tue Jul 26 18:51:02 2022] [error] [client 213.186.33.19] [host www.yaya.lu] AH01630: client denied by server configuration: /homez.639/yayasngk/www/administrator/components/com_akeeba/backup/akaccesscheck_01d7f84ead1498f268ed9920c561ddd9.txt
[Tue Jul 26 18:51:02 2022] [error] [client 213.186.33.19] [host www.yaya.lu] AH01630: client denied by server configuration: /homez.639/yayasngk/www/administrator/components/com_akeeba/backup/

Il faut prendre en compte le fait que j'ai fait hier de nombreux essais de modifications du fichier .ovhconfig sous "/www" et que certains messages d'erreurs doivent venir de là mais il y a manifestement un problème avec PHP 8.0.

Honnêtement, je ne sais pas quoi faire avec ça. Des conseils seraient les bienvenus.

Bonjour,

Il faudrait ceux d'aujourd'hui.

Cordialement, janus57

@janus57 : Ceux d'aujourd'hui ne sont apparemment pas encore disponibles, sans doute sont-ils mis à disposition avec 1 jour de décalage. Je les posterai demain.
@Fritz2cat : En cherchant sur internet, j'ai vu que vous aviez eu un problème avec des messages d'erreur similaires en février 2021 https://community.ovhcloud.com/t/23341 (voir ici). Vous rappelez-vous comment vous aviez résolu le truc ?


vous aviez eu un problème avec des messages d'erreur similaires en février 2021


Merci pour le rafraîchissement de mémoire :)
Je n'ai jamais installé de Joomla chez OVH.
J'étais dans le cas d'un cluster ancien où la rubrique "version de PHP" manquait dans l'espace client.

Bonjour,


Ceux d'aujourd'hui ne sont apparemment pas encore disponibles, sans doute sont-ils mis à disposition avec 1 jour de décalage. Je les posterai demain.

normalement il y a un lien qui permet de consultyer des logs "live" (5minutes de délais).

EDIT :



Cordialement, janus57

@janus57 : Le bouton pour les logs en live est grisé chez moi.
J'ai récupéré les logs d'hier 27/07

[Wed Jul 27 04:49:12 2022] [error] [client 93.158.90.68] [host yaya.lu] AH00690: no acceptable variant: /homez.639/yayasngk/www/robots.txt
[Wed Jul 27 15:42:37 2022] [warn] [client 10.10.10.3] [host www.yaya.lu] engine php version 7.4 not available at /var/lib/fastcgi/php//images/legacy/7.4
[Wed Jul 27 15:42:37 2022] [warn] [client 10.10.10.5] [host www.yaya.lu] engine php version 7.4 not available at /var/lib/fastcgi/php//images/legacy/7.4, referer: http://www.yaya.lu/administrator/

C'est toujours le même type d'erreur. Ce qui est curieux, c'est que j'ai fait des tests de modification du fichier .ovhconfig sous "/www" hier soir entre 18h37 et 18h43 : passage en PHP 8.0 puis tentative sans succès d'accès au backend et au frontend du site, puis retour vers PHP 7.4, ce qui aurait dû générer des erreurs.


legacy


Vous êtes certain d'avoir mis "stable" ou "stable64" sans faute ?

@Fritz2cat : Oui, les 2 fichiers .ovhconfig sont tels que reproduits dans mon post N° 16 du 27/07, je viens de vérifier.

Bonjour @Jean-ChristopheS5


container.image=stable64
app.engine.version=8.0
http.firewall=none
app.engine=php
environment=production

Et si tu mettais les lignes dans le bon ordre ??


Et si tu mettais les lignes dans le bon ordre ??


Ne me dis pas que ça peut avoir de l'importance, si c'est le cas je me demande quel est le stagiaire qui aurait programmé ça.

@MaryS : Effectivement, j'ai changé l'ordre, sans trop y croire, mais le problème persiste. Merci quand-même de m'avoir suggéré cette piste.


Ne me dis pas que ça peut avoir de l'importance, si c'est le cas je me demande quel est le stagiaire qui aurait programmé ça.


Je ne sais pas si cela en avait mais personnellement j'aurai essayé au cas ou ??

le problème persiste


Je pense à autre chose. Votre fichier, il est bien formatté en ANSI, et non en UTF-quelquechose ?

@Fritz2cat : Pas facile à savoir. Par défaut Notepad++, que j'utilise normalement, ouvre en UTF-8. J'ai sauvé en ANSI avec Notepad et ré-exporté vers mon site mais pas de changement. Je suis toujours bloqué si j'essaye de modifier ce fichier en PHP 8.0.


Je suis toujours bloqué


J'ai un NextCloud et un Wordpress qui tournent dans un hébergement où j'ai ceci comme .ovhconfig

app.engine=phpcgi
http.firewall=none
app.engine.version=8.1
environment=production
container.image=stable64

Vous pouvez aussi tenter un fichier phpinfo.php qui contient l'instruction phpinfo()
Voyez des exemples sur le web.

Bonjour,

du coup autre question, mais pourquoi vouloir PHP8.0 ?

Car là je pense que vous devez avant tout vérifier Joomla, une erreur 500 ne viendra pas du .ovhconfig mais plutôt d'une erreur PHP ou une erreur dans le .htaccess (peut probable pour le .htaccess).

Ou si vraiement vous voulez persister avec PHP8 utiliser ce .ovhconfig :
<br />app.engine.version&#61;8.0<br />container.image&#61;stable64<br />app.engine&#61;php<br />environment&#61;development<br />http.firewall&#61;none<br />
Et là si il y a bien une ou plusieurs erreurs PHP ce sera visible.

Cordialement, janus57

@janus57 : Quand j'ouvre Akeeba Backup, j'ai le message suivant :
"PHP 7.4 is approaching End–of–Life
Your site is currently using PHP 7.4.25. This version of PHP has entered its “Security maintenance” phase since Saturday, 28 May 2022 and has stopped receiving bug fixes. It will stop receiving security updates on Monday, 28 November 2022 at which point it will be unsuitable for use on a live site." C'est la raiosn pour laquelle je voulais passer à PHP 8. Sinon, je vais essayer en mode Développement.

@Fritz2cat : J'ai essayé votre .ovhconfig mais le problème persisteproblème

@everyone : Merci pour votre aide et vos conseils. j'ai fini par ouvrir un ticket chez OVH. je vous tiendrai au courant du résultat.

Bon week-end

Bonjour,


C'est la raiosn pour laquelle je voulais passer à PHP 8. Sinon, je vais essayer en mode Développement.

du coup avez-vous vérifier que TOUS vos plugins/extensions sont compatibles PHP8 ?


@everyone : Merci pour votre aide et vos conseils. j'ai fini par ouvrir un ticket chez OVH. je vous tiendrai au courant du résultat.

OVH ne fera rien, c'est pas une erreur de leur côté.
Sur du mutu le support OVH s'arrête au bon fonctionnement du service.

Cordialement, janus57