Problème d'adresse pour un nouveau site

Bonjour,
J'ai un souci avec l'adresse du site sur lequel je travaille. Il s'agit de lasauvage.site, hébergé en multisite par OVH sur une offre perso. J'ai acquis le domaine, j'ai réussi à installer wordpress et à créer mes pages (grand merci à Gaston-phone pour son guide!), et tout est en ligne. Mais j'ai du faire une mauvaise manip à un moment, puisque si on tape lasauvage.site, on tombe sur une page d'index comme celle-ci:


Pour accéder au contenu, il faut soit cliquer sur le www de cette page, soit entrer directement lasauvage.site/www.
Je précise que je ne connais pas grand-chose et qu'il y a donc de fortes chances pour que l'erreur soit toute simple… Mais j'ai quand même besoin d'aide, merci d'avance!


lasauvage.site


Bonjour,

Dans votre espace client OVH, section hébergement > Multisite, voyez ce que vous avez indiqué dans: dossier racine, et veillez à ce qu'il corresponde à ce que vous voyez dans votre espace FTP.

Merci pour la réponse!
Sur mon espace client, le dossier racine est bien .lasauvage. Sur filezilla, le site distant m'indique /home/francoiskf/.lasauvage. Dans ce /.lasauvage, il n'y a qu'un dossier, et c'est /www


/.lasauvage, il n'y a qu'un dossier, et c'est /www


Et si vous indiquiez comme dossier racine : /lasauvage/www ? (je suppose que le point ne se trouve pas dans votre nom de dossier)

Ou mieux: dans votre FTP, remonter le répertoire www d'un niveau, et indiquer que votre dossier racine est: /www

J'ai essayé d'indiquer /lasauvage/www en dossier racine, mais ça ne change rien: il faut toujours entrer lasauvage.site/www pour l'accès public.
Pour l'idée de supprimer l'étage .lasauvage, j'ai voulu commencer par sauvegarder tout le www sur mon ordi, au cas où. Et là, surprise: mon filezilla bosse, ça prend dix minutes, mais au final mon dossier de destination dans mon ordi est vide… Je nai aucune idée d'où tout a pu être mis… aaargh… Donc sans sauvegarde, je ne vais pas tenter l'autre idée…

Bonjour,

le plus simple serait de fournir une capture d'écran de la vue FileZilla + multisite

Cordialement, janus57


le plus simple serait de fournir une capture d'écran de la vue FileZilla + multisite

Je fais la même demande.


https://lasauvage.site/www ---> OK, mais les différents liens donnent une erreur 404.

Hello,

Merci tous! Voici les images demandées:



Et donc en effet je me retrouve avec plusieurs soucis en même temps…
Pour les erreur 404, c'est apparu cet après-midi, jusque là tout circulait bien. J'ai essayé de reprendre le guide de Gaston_phone au chapitre M, puisque j'avais l'impression que c'était là que j'avais merdé. J'ai donc refait ça:
Téléchargement du fichier htaccess_ssl.txt : Fichier TEXTE - htaccess_ssl.txt

Via FILEZILLA transférer ce fichier dans le dossier « /www » de votre hébergement.

Renommer : /www/.htaccess en /www/.htaccess_origine

Renommer : /www/htaccess_ssl.txt en /www/.htaccess (avec un point devant le h)

Pendant que mon filezilla moulinait pour me faire une sauvegarde, j'ai essayé d'avancer encore sur mon site en créant un formulaire de commentaire. C'est à partir de ce moment-là que j'ai commencé à avoir des erreurs: dans wordpress, un encart rose me disait en gros (j'ai pas noté le texte exact…): erreur, le JONS ne renvoie pas la bonne information. Puis je me suis aperçu que je ne pouvais plus circuler entre les pages par le menu. Le contenu est toujours là quand j'y accède par le tableau de bord. Et quand je suis revenu à filezilla, j'ai constaté que le dossier de destination de la sauvegarde était vide.Et je ne sais pas laquelle de ces manipulations a foiré…
J'ai comme l'impression qu'en essayant de réparer un truc, j'en ai abîmé d'autres…
Merci d'avance!

Bonjour,

déjà très mauvaise chose, vous avez un dossier qui commence par un point.

Perso j'enlèverais le point de devant le nom du dossier, puis dans le dossier racine du multisite je mettrais : lasauvage/www

Par contre il va falloir reprendre la configuration du wordpress pour bien tout basculer de http(s)://lasauvage.site/www/ à http(s)://lasauvage.site/

Cordialement, janus57


.lasauvage


Vous avez vraiment créé un dossier avec "point"lasauvage ?
Pourquoi ?
Sous Linux ça signifie "dossier caché".
Ce qui pourrait expliquer que vous n'avez rien retrouvé de votre téléchargement FTP, ça se trouve quand même sur votre disque dur...

Alors, il m'a semblé suivre à la lettre les instructions du guide de Gaston_phone, mais il se peut évidemment que j'ai fait une boulette au sujet de ce point. Ceci dit, j'ai bien demandé d'afficher les dossiers cachés dans mon dossier de sauvegarde et il n'y avait quand même rien.
Je viens de faire les modifications suggérées par Janus57, voici les captures:



Mais c'est le paragraphe d'après qui m'arrête:


reprendre la configuration du wordpress pour bien tout basculer de http(s)://lasauvage.site/www/ à http(s)://lasauvage.site/


Comment je fais ça…?
Merci!


Comment je fais ça...?


Si on regarde la source de votre page d'accueil qu est toute cassée, c'est parce que tout fait référence à /www
Voyez ci-dessous:


Mettez vous à la recherche d'un plugin "search and replace" afin de changer tous les https://lasauvage.site/www/ par https://lasauvage.site/ (et le même avec http)

Votre autre site francois-godard est en panne, erreur 500.

Et pour finir, une petite blague à deux balles: savez vous qui est l'inventeur de la cédille ? (en référence au titre de votre page - je n'ai pas pu m'en empêcher)

Réponse: Monsieur Groçon.

Alors, il m'a semblé suivre à la lettre les instructions du guide de Gaston_phone,

Bonjour @FrancoisG73

Il faudrait que vous m'indiquiez ce passage délictueux afin que je puisse corriger mon guide. :-)

Hihi, je la connaissais pas, et elle est très bien!
Par contre, en effet francois-godard.com est en rade et je n'y ai pas touché. Ce ne serait pas une panne chez ovh?
Pour le reste, je ne sais pas travailler en ligne de code… et du coup, d'après ce que je comprends, il faut que je cherche un plugin à partir de mon tableau de bord, sauf que je n'y accède plus, j'imagine que c'est à cause de ce que j'ai changé dans les "."
Actuellement, mon tableau de bord me renvoie ça:


1godard.comgodard.com est en rade et je n'y ai pas touché


Erreur 500: ça peut être diverses causes, du piratage de site à n'importe quoi d'autre. Ici c'est une erreur émise par le serveur web lui-même (et non un programme PHP derrière). La cause pourrait se trouver dans votre .htaccess, et la raison devrait se trouver indiquée dans votre espace client > hébergement > logs d'erreur (du jour)

https://lasauvage.site/www/wp-admin/ redirige vers lui-même en boucle infinie.

Trouvez les logins et mot de passe de votre base de données dans le fichier /lasauvage/www/wp-config.php et notez-les

Utilisez-les pour aller dans PHPmyadmin via votre espace client.

Trouvez une table qui s'appelle wp_options ou mod123_options

Les deux premières lignes Home_URL et ... contiennent l'adresse de votre site. Apportez-y les corrections nécessaires.

Trouvez une table qui s'appelle wp_options ou mod123_options

Les deux premières lignes Home_URL et ... contiennent l'adresse de votre site. Apportez-y les corrections nécessaires.


Fait! Et en effet, dorénavant l'accès public est bien lasauvage.site. Merci pour ça!
Par contre, mon accès tableau de bord wordpress est toujours cassé. Pouvez-vous m'aider là-dessus? Merci!

Par contre, mon accès tableau de bord wordpress est toujours cassé.


Videz le cache de votre navigateur.

Ca marche, merci!
J'ai l'impression que tout fonctionne à nouveau. J'ai un peu de dégâts à réparer dans les contenus mais rien de terrible. Je vérifie tout et je reposte si besoin.
Par ailleurs, je n'ai pas oublié ça


Il faudrait que vous m'indiquiez ce passage délictueux afin que je puisse corriger mon guide. :slight_smile:


ni ça:

Erreur 500: ça peut être diverses causes, du piratage de site à n'importe quoi d'autre. Ici c'est une erreur émise par le serveur web lui-même (et non un programme PHP derrière). La cause pourrait se trouver dans votre .htaccess, et la raison devrait se trouver indiquée dans votre espace client > hébergement > logs d'erreur (du jour)


je vous réponds là-dessus dès que je serai sûr que tout va bien sur le site lui-même.
Merci encore à tous!

Donc, après vérification:
- globalement tout est en place, l'accès public est au bon endroit et mon tableau de bord fonctionne
- je n'arrive pas à supprimer le formulaire de contact sur la page "le groupe", ou plus exactement je le supprime, j'enregistre, je publie, et il y est toujours… J'ai quand même l'impression qu'il y a un souci dans l'outil de formulaire wpform…
- je viens de retenter une sauvegarde via filezilla: le résultat est le même. Mon dossier de destination reste désespérément vide alors que la machine a mouliné un bon moment. Je cherche un document dans le dossier distant dont je pourrais identifier le nom pour pouvoir le chercher sur mon ordi et voir où tout est stocké, et là je m'aperçois que dans mon dossier sur l'ordi lasauvage/www/, que je suis sensé avoir créé au moment où je paramétrais le site lasauvage, sont stockées les données de l'autre site, francois-godard.com. Or il y a des années que je n'ai plus touché à ce site et que j'avais supprimé le backup ftp. Ce qui pourrait participer à l'explication de l'erreur 500 sur ce dernier… Au fur et à mesure du boulot de filezilla, je vois que tout ce qui est théoriquement transféré comprend lasauvage, alors je fais une recherche lasauvage sur mon ordi, voici le résultat:


Autrement dit, il semble bien que rien ne soit sauvegardé par l'opération sur filezilla…
Des idées?
Merci d'avance!


rien ne soit sauvegardé par l'opération sur filezilla


Si FileZilla a tout copié de A vers B, vous devriez savoir où se trouve B, c'est-à-dire vers où vous avez tout copié (et si vous avez copié dans le bon sens !)