Site inaccessible, backoffice inaccessible

Bonjour à toutes et à tous,

Mon nom de domaine est : mariellelambert.fr et j'utilise l'offre : Kimsufi 2015

Depuis près de 2 mois maintenant, mon site apparaît hors ligne. Il me semblait qu'à l'origine cela était consécutif à un changement de mon côté (changement de version PHP depuis mon tableau de bord OVH pour essayer de me mettre en conformité avec les recommandations), mais après avoir remis tous mes paramètres et rechargé des anciennes versions de ma base de données et de mon serveur FTP, rien n'y fait : mon site est inaccessible ( actuellement : "Il y a eu une erreur critique sur ce site. En apprendre plus sur le débogage de WordPress.") et je ne suis plus capable d'accéder à mon back office. En revanche, je suis capable d'identifier qu'une extension pose problème, grâce à wordpress, mais dans l'incapacité totale de la désactiver.

Voici le message que je reçois par mail :
Bonjour !

WordPress dispose d’une fonctionnalité native permettant de détecter si une extension ou un thème cause une erreur fatale sur votre site, et vous notifie avec cet e-mail automatique.


Ici, WordPress a trouvé une erreur avec l’une de vos extensions, « WooCommerce ».

Commencez par visiter votre site (https://mariellelambert.fr/) pour vérifier s’il y a des problèmes visibles. Ensuite, visitez la page où une erreur a été relevée (https://mariellelambert.fr/wp-admin/network/) et vérifiez si des problèmes sont visibles.

Veuillez contacter votre hébergeur pour une assistance concernant la résolution de ce problème.

Si votre site semble cassé ou si vous ne pouvez pas accéder à votre tableau de bord normalement, WordPress dispose maintenant d’un « mode de récupération ». Cela vous permet de vous connecter en sécurité sur votre tableau de bord afin de chercher la source du problème.

https://mariellelambert.fr/gosbus-2sexMo-hicxix/?action=enter_recovery_mode&rm_token=4GWzzuUKprsBeX4qXGxK1h&rm_key=EtuMaKFI1SZmB24ygkFo4a

Pour garder votre site en sécurité, ce lien expirera dans 1 jour. Ne vous inquiétez cependant pas : un nouveau lien vous sera envoyé si l’erreur se présente à nouveau.

Si vous cherchez de l’aide pour ce problème, les informations suivantes pourraient vous être demandées :
WordPress version 6.2.2
Thème actif : XTRA (version 4.5.2)
Extension actuelle : WooCommerce (version 7.8.2)
PHP version 7.0.33



Détails de l’erreur
======================
Une erreur de type E_PARSE a été causée dans la ligne 29 du fichier /home/mariellerz/www/wp-content/plugins/woocommerce/vendor/symfony/polyfill-php80/bootstrap.php. Message d’erreur : syntax error, unexpected '?', expecting variable (T_VARIABLE)


Je vous remercie par avance pour toute l'aide que vous pourrez m'apporter !!

PS : je suis loin d'être une experte et ce n'est pas du tout mon domaine de compétences…

Marielle


PHP version 7.0.33


Bonjour,

commencez par passer en mode development, stable64 et php 8.2

On verra après comment votre site se comporte.

http://mariellelambert.fr

Bonjour @MarielleL2

Déjà vous avez fait un gros travail d'analyse.

Mettez en service le mode développement, comme cela vous pourrez voir immédiatement la cause de l'erreur.

Voir dans mon guide le paragraphe :
**P2 - Erreur 500 - Environnement développement**

https://www.wordetweb.com/word-et-web/WORDPRESS-guide-installation-de-WordPress-premier-domaine-chez-OVH-FR.htm#_P2__-

Ceci dit, comme la fait remarquer @Fritz2cat, la PHP version 7.0.33 n'est pas géniale et obsolète. Passer en PHP 8.0 stable64 minimum.

Voir dans mon guide le paragraphe :
**F1 – Modifier la version de PHP via le manager OVH :**

https://www.wordetweb.com/word-et-web/WORDPRESS-guide-installation-de-WordPress-premier-domaine-chez-OVH-FR.htm#_F1_%E2%80%93_Modifier

**__________________________________________________________________________________**


Voici un petit guide que j'ai écrit et qui pourrait vous apporter des éclaircissements pour **une Installation complète et propre de votre Site**.

**************************************************************************************************
* **Guide - Comprendre la Relation Domaine > Zone DNS > Hébergement > Dossier du site** *
**************************************************************************************************

Voir --> **https://wordetweb.com/word-et-web/WORDPRESS-guide-installation-de-WordPress-premier-domaine-chez-OVH-FR.htm CMS - WordPress - Guide Installation chez OVH**
Contrôler votre situation en suivant **attentivement** les paragraphes : **A** à **J**

_N'hésitez pas à me faire un retour : positif ou négatif._
_C'est comme cela que je peaufine mon Guide._

_Si ce guide vous a bien aidé, n'hésitez pas à cliquer sur le bouton « j'aime »_

Bonjour @Fritz2cat et @Gaston_Phone !
Merci beaucoup pour vos retours et votre aide !!

J'ai suivi les indications du guide wordetweb, jusqu'à passer mon site en environnement de développement mais rien ne semble avoir changé…
J'ai un doute, je ne sais plus s'il y a un accès spécifique pour le back office sur ce mode spécifique ou si mon accès habituel est censé fonctionner… Quoi qu'il en soit tout est toujours inaccessible ; l'adresse du site comme mon accès back office :frowning:

PS : j'ai également changé la version de mon PHP, ce qui avait été la cause de ma perte initialement !

Merci encore,

Marielle