Smtp ovh - strapi - error

Bonjour à tous,

Je suis actuellement utilisateur d'OVH et je rencontre un problème avec l'envoi de mails via le plugin mail de STRAPI utilisant Nodemailer. Je dispose d'une offre email non professionnelle et j'utilise un VPS OVH comme backend pour une application en développement. Ce backend est basé sur STRAPI.

Mon souci se situe au niveau de l'authentification lors de l'envoi des mails. Malgré l'utilisation des mêmes identifiants que ceux avec lesquels je me connecte à ma boîte OVH (Outlook), Nodemailer affiche un message d'échec d'authentification.

Je me demande s'il y a des configurations spécifiques à prendre en compte ou des paramètres particuliers à ajuster du côté d'OVH pour permettre l'envoi de mails via Nodemailer. Toute aide ou conseil sur la résolution de ce problème serait grandement apprécié.

Voici ma configuration:

email: {
config: {
provider: 'nodemailer',
providerOptions: {
host: "ssl0.ovh.net",
port: 465,
secure: true,
logger: true,
debug: true,
auth: {
user: env('SMTP_USERNAME'),
pass: env('SMTP_PASSWORD'),
},
},
},

error: Invalid login: 535 5.7.1 Authentication failed


Merci d'avance pour votre assistance.


535 5.7.1 Authentication failed


Bonjour,

Vous mettez bien le login d'une boîte (pas d'un alias) sous sa forme e-mail complète ? Il n'y a pas d'accents dans le mot de passe ?

Voyez aussi si Secure:true veut dire "SSL" ou "TLS/StartTLS" ?

Merci pour la réponse rapide!

Effectivement il s'agit bien d'une adresse réelle et non d'un alias, voici la doc referente à secure:

TLS options
secure – if true the connection will use TLS when connecting to server. If false (the default) then TLS is used if server supports the STARTTLS extension. In most cases set this value to true if you are connecting to port 465. For port 587 or 25 keep it false

Donc c'est bien du TLS.

Il n'y a pas d'accent dans le mot de passe effectivement mais un "!", car ovh oblige un caractère special (qu'ils appellent "symbole")

merci d'avance !


For port 587 or 25 keep it false


Essayez donc false / 587

Le "!" ne devrait pas poser de problème. Il fait partie de l'ASCII de base.

Hélas j'ai déjà essayé, je fais appel à la communauté après de nombreuses recherches de mon coté, je suis peut-être passé à coté de quelque chose :frowning: ; avec cette config. j'ai une autre erreur que je n'ai pas pu résoudre non plus:

error: Greeting never received

Merci!


TLS options


Votre strapi/nodemailer, est-ce une version suffisamment récente qui supporte TLS1.2 ?

Il faut savoir que les connexions sécurisées, ça n'a pas l'air comme ça, mais pour que ça fonctionne, les deux partenaires de la connexion doivent s'accorder sur un jeu de protocoles cryptographiques qu'ils supportent tous les deux ; et si un des deux partenaires est avec une version qui date d'une dizaine d'années, parfois ils n'ont plus de "langage" commun.

Alternative: installer Postfix sur votre VPS ; et à partir de là expédier les mails en direct, voire en relais via un serveur SMTP.
Sachez que ssl0.ovh.net est a priori un serveur pour les mails transactionnels (quelques dizaines de mails par heure) et pas pour les mailings de masse.
Je ne sais pas quelle est votre volumétrie.

Oui effectivement il supporte TLS1.2,

Je vais regarder du coté de postfix!

Pour le moment c'est amplement suffisant, mais ça reste frustrant de ne pas résoudre ce problème,

Merci à vous !